Back to overview
Degraded

Limited Performance Degradation PO, INV

Mar 2, 2026 at 9:14pm UTC
Affected services
PO Automation
Invoice Automation

Resolved
Mar 2, 2026 at 10:27pm UTC

Our team has identified and resolved the root cause of this issue. Impacted transactions should be automatically resent. If you need assistance, please reach out to our support team.

Created
Mar 2, 2026 at 9:14pm UTC

We’re currently investigating an issue affecting a small number of routes, which may cause invoice and PO transactions to fail with the error: “Auto-Failed by Queue Health - removed from Queue.” Our team is working to resolve this as quickly as possible.