Back to overview
Degraded

Intermittent delays in processing of Transactions

Jan 08 at 05:00pm EST
Affected services
PunchOut Catalog
PO Automation
Invoice Automation

Resolved
Jan 08 at 05:56pm EST

This status alert has been resolved.

Created
Jan 08 at 05:00pm EST

TradeCentric experienced a processing delay from 10 AM to approximately 12:45 AM EST on January 8, 2026 that caused some transactions to time out and not complete. The issue may have impacted any transaction type. The cause has been identified, and the incident has been resolved. For questions or concerns, please contact our support team at support@tradecentric.com.